usegalaxy.org is unavailable for scheduled network maintenance
Incident Report for The Galaxy Project
Resolved
This incident has been resolved.
Posted Nov 28, 2021 - 22:00 UTC
Identified
Network services for UseGalaxy.org are down for scheduled maintenance. We apologize for the lack of advance notice.
Posted Nov 28, 2021 - 16:00 UTC
This incident affected: Galaxy Main (Webserver 1, Webserver 2) and Support & Test Servers (Test Galaxy).