Galaxy Australia Service Unavailable
Incident Report for The Galaxy Project
Resolved
This incident has been resolved.
Posted 3 months ago. May 31, 2019 - 14:54 UTC
Investigating
We are currently experiencing an issue with part of the data centre that houses Galaxy Australia. Galaxy Australia is currently unavailable. We are investigating the issue and hope to have service back up as soon as possible.
Posted 3 months ago. May 31, 2019 - 13:57 UTC
This incident affected: Galaxy Australia.