usegalaxy.org is unreachable
Incident Report for The Galaxy Project
Resolved
Connectivity has been restored and the site is functioning normally.
Posted Nov 04, 2024 - 22:37 UTC
Investigating
usegalaxy.org is currently offline due to connectivity problems at our host. We will update the issue when we have more information about the cause of the outage and an expected recovery time.
Posted Nov 04, 2024 - 22:26 UTC
This incident affected: Galaxy Main (Webserver 1, Webserver 2).